import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = ".*told me to say.*";
        final String string = "ex1: I am * years old\n"
	 + "valid matches:\n"
	 + "- \"I am 24 years old\"\n"
	 + "- \"I am twenty four years old\"\n\n"
	 + "ex2: what color is [my|your|his|her] (bright red|blue|green|lemon chiffon) *\n"
	 + "valid matches:\n"
	 + "- \"what color is his lemon chiffon car\"\n"
	 + "- \"what color is my some random text till the end of string\"\n\n"
	 + "ex3: [*] told me to say *\n"
	 + "valid matches:\n"
	 + "- \"Bob and Alice told me to say hallelujah\"\n"
	 + "- \"told me to say by nobody\"";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}