package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/importantpage/?(.*?)$`)
var str = `/importantpage/aSECRETvalue33
/importantpage
/importantpageisnothere/some/other/path`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}