$re = '`^/importantpage/?(.*?)$`m';
$str = '/importantpage/aSECRETvalue33
/importantpage
/importantpageisnothere/some/other/path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);