re = /^\/importantpage\/?(.*?)$/m
str = '/importantpage/aSECRETvalue33
/importantpage
/importantpageisnothere/some/other/path'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end