package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+98|0|0098)?9\d{9}$`)
var str = `09121234567
00989121234567
+989121234567
9121234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}