$re = '/^(\+98|0|0098)?9\d{9}$/m';
$str = '09121234567
00989121234567
+989121234567
9121234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);