const regex = /<span>(?:[^<]|<(?!span>|\/span>))*<\/span>/sig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span>(?:[^<]|<(?!span>|\\\/span>))*<\\\/span>', 'sig')
const str = `Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}