import re
regex = re.compile(r'(\'|"")My-Text(\'|""):.*?((input-src|output-src|x-src)).*?(?!(perfect-inline|perfect-eval|\*))', flags=re.MULTILINE)
test_str = ("{''Remote-Control': 'no-control, must', 'My-Text': \"input-src 'something' 'perfect-out' 'perfect-in' *.exampl.com\", 'Some': '1; 'Encoding': 'gzip'}\n"
"{''Remote-Control': 'no-control, must', 'My-Text': \"input-src *\", 'Some': '1; 'Encoding': 'gzip'}\n"
"{''Remote-Control': 'no-control, must', 'My-Text': \"output-src *.exampl.com\", 'Some': '1; 'Encoding': 'gzip'}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")