re = /(\'|"")My-Text(\'|""):.*?((input-src|output-src|x-src)).*?(?!(perfect-inline|perfect-eval|\*))/m
str = '{\'\'Remote-Control\': \'no-control, must\', \'My-Text\': "input-src \'something\' \'perfect-out\' \'perfect-in\' *.exampl.com", \'Some\': \'1; \'Encoding\': \'gzip\'}
{\'\'Remote-Control\': \'no-control, must\', \'My-Text\': "input-src *", \'Some\': \'1; \'Encoding\': \'gzip\'}
{\'\'Remote-Control\': \'no-control, must\', \'My-Text\': "output-src *.exampl.com", \'Some\': \'1; \'Encoding\': \'gzip\'}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end