#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[A-Za-z]+\d+|\d+[A-Za-z]+)[A-Za-z\d]*$"
Local $sString = "For example, adfak332arg3 is allowed but 332352 and fagaaah are not allowed. .*[^\\s] looks fine for strings with only chars but how to fix it to accepts the desired strings and refuses the other two types?" & @CRLF & _
"" & @CRLF & _
"adfak332arg3" & @CRLF & _
"a3" & @CRLF & _
"6b" & @CRLF & _
"9gag" & @CRLF & _
"t3" & @CRLF & _
"int32" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"332352" & @CRLF & _
"fagaaah" & @CRLF & _
"abduecuijaidkeaodk" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")