use strict;
my $str = 'For example, adfak332arg3 is allowed but 332352 and fagaaah are not allowed. .*[^\\\\s] looks fine for strings with only chars but how to fix it to accepts the desired strings and refuses the other two types?
adfak332arg3
a3
6b
9gag
t3
int32
332352
fagaaah
abduecuijaidkeaodk
';
my $regex = qr/^(?:[A-Za-z]+\d+|\d+[A-Za-z]+)[A-Za-z\d]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}