$re = '/^(?:[A-Za-z]+\d+|\d+[A-Za-z]+)[A-Za-z\d]*$/m';
$str = 'For example, adfak332arg3 is allowed but 332352 and fagaaah are not allowed. .*[^\\\\s] looks fine for strings with only chars but how to fix it to accepts the desired strings and refuses the other two types?
adfak332arg3
a3
6b
9gag
t3
int32
332352
fagaaah
abduecuijaidkeaodk
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);