import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,:\\n\\r]+):(.*(?:\\R(?![^,:\\n\\r]+:).*)*)";
final String string = "Name: John Doe\n\n"
+ "Age: 23\n\n"
+ "Primary Language: English\n\n"
+ "Description: This is a multiline\n"
+ "description field that I want \n"
+ "to capture Fri, 02 Sep 2022 14:46:45 -0500\n\n"
+ "Country: Canada";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}