# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^,:\n\r]+):(.*(?:\R(?![^,:\n\r]+:).*)*)"
test_str = ("Name: John Doe\n\n"
"Age: 23\n\n"
"Primary Language: English\n\n"
"Description: This is a multiline\n"
"description field that I want \n"
"to capture Fri, 02 Sep 2022 14:46:45 -0500\n\n"
"Country: Canada")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.