const regex = /^([^,:\n\r]+):(.*(?:\R(?![^,:\n\r]+:).*)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^,:\\n\\r]+):(.*(?:\\R(?![^,:\\n\\r]+:).*)*)', 'gm')
const str = `Name: John Doe
Age: 23
Primary Language: English
Description: This is a multiline
description field that I want
to capture Fri, 02 Sep 2022 14:46:45 -0500
Country: Canada`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}