import re
regex = re.compile(r"\bBuilding: ([A-Z]+(?: (?!UNIT\b)[A-Z]+\b)*)", flags=re.MULTILINE)
test_str = ("Building: BUILDING ONE 15 [building name followed by unit number]\n"
"Optional preceding text Building: BUILDING ONE 15 [preceding text, then building name followed unit number]\n"
"Building: BUILDING ONE UNIT 15 [building name followed by word UNIT and unit number]\n"
"Building: BUILDING ONE Floor 2 [building name followed by mixed case word]\n"
"Grounds: OPEN SPACE WEST Section 3 [not a building - return nothing]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")