re = /\bBuilding: ([A-Z]+(?: (?!UNIT\b)[A-Z]+\b)*)/m
str = 'Building: BUILDING ONE 15 [building name followed by unit number]
Optional preceding text Building: BUILDING ONE 15 [preceding text, then building name followed unit number]
Building: BUILDING ONE UNIT 15 [building name followed by word UNIT and unit number]
Building: BUILDING ONE Floor 2 [building name followed by mixed case word]
Grounds: OPEN SPACE WEST Section 3 [not a building - return nothing]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end