using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(?:tom|fred|jim)\/?.*$";
string input = @"/bob/fred/tom/jack
/bob/tom/jack
/bob/tom/
/bob/tom
/bob/jack
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}