#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(K|k)ang(a|u)r(o{2}|u)s?"
Local $sString = "Kangaroo" & @CRLF & _
"kangaroos" & @CRLF & _
"Kangaroos" & @CRLF & _
"kangaroo" & @CRLF & _
"kanguru" & @CRLF & _
"Kangurus" & @CRLF & _
"kangurus" & @CRLF & _
"Kanguru"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")