re = /(K|k)ang(a|u)r(o{2}|u)s?/m
str = 'Kangaroo
kangaroos
Kangaroos
kangaroo
kanguru
Kangurus
kangurus
Kanguru'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end