package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(K|k)ang(a|u)r(o{2}|u)s?`)
var str = `Kangaroo
kangaroos
Kangaroos
kangaroo
kanguru
Kangurus
kangurus
Kanguru`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}