using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\""'])(?:\\.|(?!\1)[^\\])*?\1(*SKIP)(*F)|(?:[^\\""']|\\.)+";
string input = @"Lorem ipsum ""dolor"" sit amet, consectetur ""adipiscing"" elit.
Nunc ultrices varius odio, ""ut accumsan nisi"" aliquet vitae.
""Ut faucibus augue tortor, at aliquam purus dignissim eget.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}