$re = '/([\"\'])(?:\\\\.|(?!\1)[^\\\\])*?\1(*SKIP)(*F)|(?:[^\\\\"\']|\\\\.)+/';
$str = 'Lorem ipsum "dolor" sit amet, consectetur "adipiscing" elit.
Nunc ultrices varius odio, "ut accumsan nisi" aliquet vitae.
"Ut faucibus augue tortor, at aliquam purus dignissim eget."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);