import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\\"'])(?:\\\\.|(?!\\1)[^\\\\])*?\\1(*SKIP)(*F)|(?:[^\\\\\"']|\\\\.)+";
final String string = "Lorem ipsum \"dolor\" sit amet, consectetur \"adipiscing\" elit.\n"
+ " Nunc ultrices varius odio, \"ut accumsan nisi\" aliquet vitae.\n"
+ " \"Ut faucibus augue tortor, at aliquam purus dignissim eget.\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}