package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x)
https?://
(?:
(?:www|m)\.
(?:tiktok.com)\/
(?:v|embed|trending)
(?:\/)?
(?:\?shareId=)?
)
(?P<id>[\da-z]+)`)
var str = `https://m.tiktok.com/h5/share/usr/6641141594707361797.html
https://m.tiktok.com/v/6749869095467945218.html
https://www.tiktok.com/@cchelseameow/video/6751181801206729990
https://www.tiktok.com/embed/6567659045795758085
https://www.tiktok.com/share/user/6567659045795758085
https://www.tiktok.com/trending?shareId=6744531482393545985`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}