import re
regex = re.compile((r"(?x)\n"
r"https?://\n"
r"(?:\n"
r" (?:www|m)\.\n"
r" (?:tiktok.com)\/\n"
r" (?:v|embed|trending)\n"
r" (?:\/)?\n"
r" (?:\?shareId=)?\n"
r")\n"
r"(?P<id>[\da-z]+)"), flags=re.MULTILINE)
test_str = ("https://m.tiktok.com/h5/share/usr/6641141594707361797.html\n"
"https://m.tiktok.com/v/6749869095467945218.html\n"
"https://www.tiktok.com/@cchelseameow/video/6751181801206729990\n"
"https://www.tiktok.com/embed/6567659045795758085\n"
"https://www.tiktok.com/share/user/6567659045795758085\n"
"https://www.tiktok.com/trending?shareId=6744531482393545985")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")