const regex = /(?![0-6][0-4][0])[0-9]{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![0-6][0-4][0])[0-9]{3}', 'gm')
const str = `So it would match 664 and 641, but not 440 and 640.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}