re = /(?![0-6][0-4][0])[0-9]{3}/m
str = 'So it would match 664 and 641, but not 440 and 640.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end