$re = '/(?=.*\bRing\b.*)(?=.*\bbinden\b.*).*\bDunkel\b.*/';
$str = 'Ein Ring, sie zu knechten, sie alle zu finden ins Helle zu treiben und ewig zu binden';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);