#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0\.[1-9]|[1-9][0-9]*)(\.[0-9]|m?)$"
Local $sString = "0.0" & @CRLF & _
"0" & @CRLF & _
"0m" & @CRLF & _
"" & @CRLF & _
"0.1" & @CRLF & _
"1.1" & @CRLF & _
"10.1" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"20" & @CRLF & _
"" & @CRLF & _
"1m" & @CRLF & _
"10m" & @CRLF & _
"100m" & @CRLF & _
"1000m" & @CRLF & _
"10000m"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")