# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0\.[1-9]|[1-9][0-9]*)(\.[0-9]|m?)$"
test_str = ("0.0\n"
"0\n"
"0m\n\n"
"0.1\n"
"1.1\n"
"10.1\n\n"
"1\n"
"20\n\n"
"1m\n"
"10m\n"
"100m\n"
"1000m\n"
"10000m")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.