import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0\\.[1-9]|[1-9][0-9]*)(\\.[0-9]|m?)$";
final String string = "0.0\n"
+ "0\n"
+ "0m\n\n"
+ "0.1\n"
+ "1.1\n"
+ "10.1\n\n"
+ "1\n"
+ "20\n\n"
+ "1m\n"
+ "10m\n"
+ "100m\n"
+ "1000m\n"
+ "10000m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}