import re
regex = re.compile(r"(^<.+?name=)\".+?\"(.+? linkedscene=)\"(.+?)\"(.+\>)", flags=re.MULTILINE)
test_str = "<hotspot name=\"xxxxx\" style=\"hs_circle\" ath=\"150.712\" atv=\"13.351\" linkedscene=\"landing2\" tag=\"Landing\" />"
subst = "$1\"$3\"$2\"$3\"$4"
result = regex.sub(subst, test_str)
if result:
print(result)