re = /(^<.+?name=)".+?"(.+? linkedscene=)"(.+?)"(.+\>)/m
str = '<hotspot name="xxxxx" style="hs_circle" ath="150.712" atv="13.351" linkedscene="landing2" tag="Landing" />'
subst = '$1"$3"$2"$3"$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result