using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"999[0-9]{2}([0-8][0-9]|91|90)";
string input = @"9990001 - 9999991";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}