$re = '/999[0-9]{2}([0-8][0-9]|91|90)/';
$str = '9990001 - 9999991';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);