package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`999[0-9]{2}([0-8][0-9]|91|90)`)
var str = `9990001 - 9999991`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}