#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^-\n]*[^\s-][^-\n]*?)\s*-\s*([^-\n]*[^\s-][^-\n]*)$"
Local $sString = "umbrela - gray" & @CRLF & _
"umbrela test - gray ish" & @CRLF & _
" - " & @CRLF & _
" - test" & @CRLF & _
"-test" & @CRLF & _
"test-" & @CRLF & _
"test -" & @CRLF & _
"test-test" & @CRLF & _
"test- test" & @CRLF & _
"test - test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")