$re = '/^([^-\n]*[^\s-][^-\n]*?)\s*-\s*([^-\n]*[^\s-][^-\n]*)$/m';
$str = 'umbrela - gray
umbrela test - gray ish
-
- test
-test
test-
test -
test-test
test- test
test - test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);