package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^-\n]*[^\s-][^-\n]*?)\s*-\s*([^-\n]*[^\s-][^-\n]*)$`)
var str = `umbrela - gray
umbrela test - gray ish
-
- test
-test
test-
test -
test-test
test- test
test - test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}