$re = '//DomainId\/(?P<DomainId>\d{5,9})\b|/DomainainSiteId\/(?P<DomainainSiteId>\d{5,9})\b/m';
$str = 'https://company.db.abcd.com/DomainId/123456789/Other https://company.db.abcd.com/DomainainSiteId/123456/Other https://companyaddedwords.db.abcd.com/DomainId/1234567/Other';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);