re = /\/DomainId\/(?P<DomainId>\d{5,9})\b|\/DomainainSiteId\/(?P<DomainainSiteId>\d{5,9})\b/m
str = 'https://company.db.abcd.com/DomainId/123456789/Other https://company.db.abcd.com/DomainainSiteId/123456/Other https://companyaddedwords.db.abcd.com/DomainId/1234567/Other'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end