using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+?@.+?\.autos";
string input = @"From: ""Costco Rewards"" <costco.rewards@callipygianhalcyon.autos>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}