re = /.+?@.+?\.autos/
str = 'From: "Costco Rewards" <costco.rewards@callipygianhalcyon.autos>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end