import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/dir/apdir/(?!subdir/index\\.php|js/idexfile/file\\.php).+\\.(php|cgi|pl|phtml)";
final String string = "\n"
+ "/dir/apdir/subdir/index.php\n"
+ "/dir/apdir/js/idexfile/file.php\n"
+ "/dir/apdir/index.php\n"
+ "/dir/apdir/js/idexfile/file_1.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}