import Foundation
let pattern = #"^/dir/apdir/(?!subdir/index\.php|js/idexfile/file\.php).+\.(php|cgi|pl|phtml)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/dir/apdir/subdir/index.php
/dir/apdir/js/idexfile/file.php
/dir/apdir/index.php
/dir/apdir/js/idexfile/file_1.php
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)