$re = '~^/dir/apdir/(?!subdir/index\.php|js/idexfile/file\.php).+\.(php|cgi|pl|phtml)~m';
$str = '
/dir/apdir/subdir/index.php
/dir/apdir/js/idexfile/file.php
/dir/apdir/index.php
/dir/apdir/js/idexfile/file_1.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);