using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\=(.*?)\&";
string input = @"download.php?id=6f7718e8f59c8d868225bf915f4a6050fa02c486&f=Koda+Fratello+Orso+-+1080p.torrent.torrent";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}