$re = '/\=(.*?)\&/m';
$str = 'download.php?id=6f7718e8f59c8d868225bf915f4a6050fa02c486&f=Koda+Fratello+Orso+-+1080p.torrent.torrent';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);