re = /\=(.*?)\&/m
str = 'download.php?id=6f7718e8f59c8d868225bf915f4a6050fa02c486&f=Koda+Fratello+Orso+-+1080p.torrent.torrent'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end